Recent Updates Page 2 Toggle Comment Threads | Keyboard Shortcuts

  • captainigloo 1:37 pm on January 14, 2009 Permalink | Reply  

    I’m going to FOSDEM and you ? 

    I’m going to FOSDEM, the Free and Open Source Software Developers’ European Meeting

     
  • captainigloo 8:33 pm on October 21, 2008 Permalink | Reply
    Tags:   

    Premiers pas dans la Domotique 

    L’hiver approche à grand pas, et la température intérieure diminue un peu plus tous les jours. Il faudra bientôt allumer le chauffage ! L’appartement est grand avec de beaux volumes comme ils disent dans les agences immobilière. En gros ça veux dire appartement très difficile a chauffer. Bien sur l’installation est électrique. Mais l’avantage c’est que les propriétaires ont mis des chauffages électriques radial. N’y a t’il pas un moyen de contrôler ces chauffages ? De ne pas revivre le froid saisissant des l’appartement quand on rentre le soir du travail ? Faire en sorte que ces chauffages maintiennent une température agréable quand on est la, et faire en sorte que la température ne redescende pas en dessous de 15° pendant la journée et la nuit. Rien de plus désagréable que de déjeuner dans une pièce le matin ou il fait froid.

    A chaque fois que je tourne la molette de réglage du chauffage, il y a un petit détail qui attire mon oeil. Un pictogramme ressemblant a une horloge. A quoi ca peut bien servir ?

    Molette de réglage

    Molette de réglage

    (More …)

     
    • FRILEUX 8:28 pm on October 27, 2008 Permalink | Reply

      Bonsoir,
      je vais effectuer le même montage. Mais une question reste, vous avez branché sur un domino les 3 fils bleus, puis les 3 fils marrons et enfin les 3 fils noirs ? Est ce bien cela? Pourriez vous rajouter une photo du branchement ?
      Cordialement

    • captainigloo 10:32 am on November 1, 2008 Permalink | Reply

      Bonjour,

      J’ai ajouté dans mon billet un modeste plan de cablage. J’espére que ce sera plus clair.
      Je tiens à préciser que les fils pilote des convecteurs ne sont pas cablés sur le tableau électrique. Donc je n’ai que la phase et le neutre qui sortent du mur.
      Ensuite je branche la phase/neutre du convecteur à la phase/neutre du réseau électrique. (C’est le cablage initial). Et je rajoute la phase et le neutre du module Am12W.
      Ensuite J’ai jouté un nouveau domino pour cabler le fil pilote du module X10 au fil pilote du convecteur.
      J’ai vu sur le net des montages qui rajoutent une résistance en série au niveau du fil pilote. Je n’ai pas eu a l’ajotuer puisque suite a mes tests “ca marche chez moi” 🙂

    • Alex 12:22 pm on December 13, 2008 Permalink | Reply

      Bonjour,

      vous avez visiblement choisi un CM11 avec une prise USB bien que vous envisagiez de l’utiliser sous Linux. Or, j’ai lu à nombreuses reprises qu’il y avait des problèmes d’instabilité sous Linux en USB pour ce module X10 (nécessité de débrancher/rebrancher le module X10 qui ne réagit plus par exemple). Avez vous rencontré ces problèmes ou tout fonctionne-t-il parfaitement ?
      Quel est le driver USB utilisé par Linux pour piloter le CM11 ? Quelle distribution utilisez-vous ?

      merci d’avance pour vos réponses et conseils

      • captainigloo 1:34 pm on January 14, 2009 Permalink | Reply

        Bonjour,
        Vous avez tout a fait raison, j’ai choisis la version CM11 avec prise USB. Mais heureusement, cette version était livrée également avec une liaison série.
        En réalité, la liaison USB est réalisée par un adaptateur USB/série Cette version est effectivement bugguée sous linux. La connexion se fait correctement, mais aléatoirement la communication se bloque. En passant par la liaison série, sa connexion est tres bonne.

        Si vous devez obligatoirement passer par une liaison USB, je pense que le mieux est de passer par un module de conversion USB/série de chez FTDI, dont les drivers sont bien mieux supportés sous GNU/Linux. La connextion sera cependant a modifier puisque le module utilise une connectique de type RJ11.

        J’utilise Ubuntu 8.04 Server edition.

        PS : Désolé pour le retard, je n’ai pas vu le commentaire !

  • captainigloo 12:24 pm on October 18, 2008 Permalink | Reply
    Tags: , Enlightenment, ,   

    Enna Compilation on Ubuntu 

    As neither eina nor EFL are released, you must compile them. They are Ubuntu packages for EFL but they are old, and API have changed. If you use them, compilation should failed. It’s better to compile all libraries with your little fingers 🙂
    The result :

    Enna Main Menu

    Enna Main Menu

    (More …)

     
    • elis 10:26 pm on October 21, 2008 Permalink | Reply

      I just tried out the latest version in svn/hg and I must say I am pretty excited on how this project will turn out.

      Add TV-support and I will install this on my HTPC as soon as it reaches product quality.

      Keep up the nice work!

    • Mathieu SCHROETER 8:28 pm on October 24, 2008 Permalink | Reply

      And in order to use libplayer, don’t forget:

      sudo aptitude install mplayer

    • daryl 11:17 pm on October 31, 2008 Permalink | Reply

      whoa…. I have seen enna in CVS (now svn) for some time now. This is the first time I have seen in up an going. As the easy_e17 script skipped rage I am assuming that this is not the media center app for e17???

      Ok I like it but here is my one question. I am a CEDIA certified home theater installer and I can not live without surround sound. I know how to send commands to mplayer instructing it to utilize alsa to pass through the ac3 and dts audio tracks. I am not familiar with libplayer but I am wondering if the context is the same? Will the same commands that tell mplayer to preserve and not to downmix that beautiful 5.1 track be applicable to Enna?

    • captainigloo 10:26 am on November 1, 2008 Permalink | Reply

      I think that rage is not a full mediacenter app. It’s Raster’s toy. This app is in E SVN to show what we can do with EFL. Enna is more a mediacenter app, and is more usefull.

      For you mplayer question, I’m not 100% sure that what you want to do is possible, but I guess mplayer options are compatible with enna. Mathieu and Ben (libplayer’s authors) could answer better but I think that mplayer options in $HOME/.mplayer are not overrided by enna. So ac3 adn dts track could be play like you do without enna. Enna just embeded mplayer window.
      If you use emotion as main enna backend, you can’t do this.

    • Mathieu SCHROETER 12:08 pm on November 1, 2008 Permalink | Reply

      Nico you are right!

      Just put the configuration in ~/.mplayer/config, the file will be read by MPlayer.

    • Sanzoghenzo 7:30 pm on November 4, 2008 Permalink | Reply

      Hi
      I know that it’s a obvious thing for a power user like us 🙂 , but you mistyped the autogen.sh line… it’s “–prefix” instread of “-prefix”. Newbie may be in trouble with this!
      Just installed… looks very very nice!
      cheers

    • captainigloo 8:38 pm on November 4, 2008 Permalink | Reply

      It’s seems that they are a problem in WordPress CSS. – – are render as juste one -. When you do a copy/paste into terminal, – – are transorfmed in a bad character. I should maybe change the current theme to avoid this kind of problem !
      Thanks for this report :).

    • alex 5:15 pm on February 8, 2009 Permalink | Reply

      hai after compiling all and everthing done
      went i try to call enna in new terminal box, then enna raise this error = enna: error while loading shared libraries: libembryo.so.0: cannot open shared object file: No such file or directory
      can anybody help me ?

      thanks
      alex

    • alex 3:21 am on February 9, 2009 Permalink | Reply

      hai i have solve my problem with restarting ubuntu, thx,
      now my problem is enna is run but the window is blank , how can i fix it thanks

    • Urahara 10:08 pm on February 26, 2009 Permalink | Reply

      Doesn’t work 😦

      $ enna
      [Enna] [module.c:23] Info: Plugin Directory: /usr/lib/enna/modules/
      [Enna] [module.c:26] Info: Available Plugins:
      [Enna] [module.c:29] Info: Segmentation fault

    • Stefan 9:47 pm on March 6, 2009 Permalink | Reply

      Hi,

      Can someone help me with the following:

      checking for ENNA… configure: error: Package
      ….
      No package ‘elementary’ found

      Regards,
      -Stefan

    • Stefan 7:53 am on March 7, 2009 Permalink | Reply

      Found this on efl:

      svn co http://svn.enlightenment.org/svn/e/trunk/TMP/st/elementary

      cd elementary
      ./autogen.sh
      make
      sudo make install

    • Stefan 8:30 am on March 7, 2009 Permalink | Reply

      Hi,
      I’m stuck again when making enna. The error I get is:

      enna_module_photo.c: In function ‘_create_menu’:
      enna_module_photo.c:378: error: ‘Enna_Module_Photo’ has no member named ‘item_class’

      Can someone assist me with this?

      Regards,
      -Stefan

    • captainigloo 9:19 am on March 7, 2009 Permalink | Reply

      Hi Stefan,
      It’s a bit compilicated to compile enna these days, As i have done some changes, add elementary as have seen. Last week E guys have break some of EFL api so I had to change some part of enna too.
      Today I think that you should compile without problem.

      First you must have all uptodate libs from E17. To update your libs :
      svn update
      ./autogen.sh –prefix=/usr
      make
      make install
      for each libs :
      eina, eet, embryo, ecore, edje, elementary, libplayer, libvalhalha, and enna.
      libvahala is new , but in a very good shape, and developped by Mat. I think that i will blog about this in a near future.
      Hope that this infos help you

      Nico

    • captainigloo 9:25 am on March 7, 2009 Permalink | Reply

      oops livalhala can be found on geexbox repository.
      So if you want test it : hg clone http://hg.geexbox.org/libvalhalla/

    • Stefan 10:34 pm on March 7, 2009 Permalink | Reply

      thank you!

    • Stefan 10:42 pm on March 7, 2009 Permalink | Reply

      FYI; all the EFL libraries where at head (39412) but I still get the same error. I will keep trying 🙂

      • captainigloo 11:35 am on March 8, 2009 Permalink | Reply

        you have maybe some of them installed in /usr/local/lib ?

    • eric 10:35 am on April 18, 2009 Permalink | Reply

      i have the same problem as Stefan. maybe the dmesg may help:

      enna[14784] general protection ip:7f80fa9ec460 sp:7fff05bd5198 error:0 in libc-2.9.so[7f80fa972000+14a000]

    • Chris 9:41 pm on April 27, 2009 Permalink | Reply

      Hi, I get stuck while making enna. This is whats get printed:

      [root@localhost enna]# make
      config.status: creating config.h
      config.status: config.h is unchanged
      Making all in src
      Making all in bin
      LINK enna
      mediaplayer.o: In function `enna_mediaplayer_init’:
      /home/chris/Documents/enna/src/bin/mediaplayer.c:792: undefined reference to `ECORE_EVENT_KEY_DOWN’
      /home/chris/Documents/enna/src/bin/mediaplayer.c:794: undefined reference to `ECORE_EVENT_MOUSE_BUTTON_DOWN’
      /home/chris/Documents/enna/src/bin/mediaplayer.c:797: undefined reference to `ECORE_EVENT_MOUSE_MOVE’
      collect2: ld returned 1 exit status
      make[3]: *** [enna] Error 1
      make[2]: *** [all-recursive] Error 1
      make[1]: *** [all-recursive] Error 1
      make: *** [all] Error 2

      The root of the problem may be that I haven’t successfully installed the libvalhalla, I’m missing libavformat which I cannot find on the urpmi. Anyone?

    • alexandre 11:36 am on October 3, 2009 Permalink | Reply

      Enna looks really great, but I get a problem while compiling enna, it tells me there is “No package ‘libvalhalla’ found”.

      And when I want to compile libvalhalla, I get the following error :

      ~/libvalhalla$ ./configure && make && sudo make install
      Checking for compiler available…
      Checking for libavformat …
      Checking for sqlite3 …
      Checking for libcurl …
      Checking for libxml2 …
      Checking for libexif …
      Package libnfo was not found in the pkg-config search path.
      Perhaps you should add the directory containing `libnfo.pc’
      to the PKG_CONFIG_PATH environment variable
      No package ‘libnfo’ found
      Package libnfo was not found in the pkg-config search path.
      Perhaps you should add the directory containing `libnfo.pc’
      to the PKG_CONFIG_PATH environment variable
      No package ‘libnfo’ found
      Checking for libnfo …
      Error, can’t find libnfo !
      See file “config.log” produced by configure for more details.

      I hope you will help me, I don’t no the way I can get libnfo, when I did sudo apt-cache search libnfo, I got nothing.

    • chetan 6:00 am on January 7, 2010 Permalink | Reply

      Hi,

      has anyone successfully built MPlayer (not Media Player) for a Windows
      CE device? If so, any recommendations to get started is gratefully
      received.

      What I want to achieve is to play video and audio from RTP streams.

      Best regards!
      chetan singh

  • captainigloo 10:46 am on October 18, 2008 Permalink | Reply
    Tags: wordpress   

    Hosted by WordPress 

    Hi folks,
    Long time elapsed since my last post, the main reason is that digital-corner is no longer hosted by AMEN. They were too expensive. So I decided to keep them as registrar, but this blog is now hosted by WordPress.
    I must say that I’m very happy with services that wordpress provides. The blog interface is really easy too use. And the setup take only few minutes.
    I discover that wordpress hosted blogs, after reading Ben and Mat’s blogs. They are blogging about GeexBox and Enna, you should read their blogs if you want to have some infos about Enna and GeexBox development progress.

     
  • captainigloo 10:45 am on October 18, 2008 Permalink | Reply  

    Enna Development process 

    They are a lot of changes in Enna development process.

    2 month ago Ben have imported Enna svn in Geexbox Mercurial repository. Mercurial is a distributed revision control sofware, exactly like Git. So since Mon, 18 Aug 2008, enna development take place in the official GeexBox repository.

    Why ?

    First, as geexbox deveveloppers are the main contributors to enna source code, it’s simplier to have development in their repository.The second reaseaon, is that i’m very excited to see enna integrated into next version of Geexbox (2.0). So hosted RCS enna in gb repository take sense and development is faster. The third reason, is that enna is always hosted in the SVN Enlightenment repository, so old Sourceforge SVN is now deprecated.

    We add new feature in mercurial. And when a feature is complete, I synchronize Mercurial with Enlightenment SVN.

    So how to do to retrieve source code ?

    Geexbox Mercurial repository :

    If you want to test the last code, it means that sometimes compilation may be broken you can retrieve the mercurial version :

    hg clone http://hg.geexbox.org/enna

    And if you want update

    hg pull -u

    Enlightenment SVN repository :

    If you want a version that is more stable (but always in development) you can retrieve Enlightenment SVN trunk :

    svn co http://svn.enlightenment.org/svn/e/trunk/MISC/enna

    And if you want update :

    svn up

     
  • captainigloo 4:11 pm on June 3, 2008 Permalink | Reply
    Tags: Digital-corner,   

    Migration de digital-corner.org 

    Depuis une semaine maitenant, http://www.digital-corner.org a changé de place. Il ya 3 ans, lorsque je me suis lancé dans l’écriture de Enna, j’ai acheté ce nom de domaine avec un pack 50Mo, une base mysql et un Php préinstallé. A l’époque je me demandai ce que j’allais bien pouvoir faire de ces 50Mo. Mais apres avoir installé plusieurs CMS (joomla, modx et maintenant drupal) et avoir perdu les droits d’écriture sur certains fichier, les 50Mo ne suffisaient plus. Depuis une semaine digital-corner a donc changé de serveur toujours chez Amen, avec 5Go 5 base mysql et plein d’autre bonus dont je ne me servirais surement pas.

    Cette migration m’a permit de fignoler la config Drupal, d’ajouter une authentification reCaptcha sur les commentaires qui ne fonctionnait pas sur l’ancien serveur, ne me demandai pas pourquoi, certainement encore une fois les droits d’écriture perdu sur un fichier ….
    Je vais essayer dans les jours futur d’amliorer le theme du site, pour qu’il soit plus personalisé et plus proche de l’esprit de Enna. J’ajouterai également une section maemo/N810 pour que les personnes qui le souhaitent puisse tester le nouveau Enna sur leur N8x0.

     
  • captainigloo 12:02 pm on May 26, 2008 Permalink | Reply
    Tags: , , Geexbox, libplayer   

    Road to Enna NextGen 

    For Two month, I’m writing new version of Enna. As you can see In my previous post, this version run on Maemo. But the main goal is always to write a complete Media Center arround EFL libs for PC. You can found this new version here :

    svn co https://enna.svn.sourceforge.net/svnroot/enna/trunk/ng/enna enna
    and as usual :
    cd enna && ./autogen.sh && make && make install

    At the moment you should be able to play music file if you have backend compiled and installed. The first backend you can use is emotion. But this weekend GeeXBox Guys added new backend based on libplayer. Thanks Ben to have added this new feature. Development go fast, and I hope to release an alpha version soon with few features : Only Music and Video playback. Development of new modules is fast (Only 1 hour to write libplayer backend for example) and new plugins should come soon.
    I tought to write squeezecenter plugin, to control this network player with enna.
    And if i have time, I will provide deb packages for maemo.

    More comming soon 🙂

     
    • Another Nico 2:14 pm on November 18, 2009 Permalink | Reply

      hello nico
      did you integrate squeezebox server in the end? that was an AWESOME idea i think
      im installing e17 right now, cant wait to give you feedback on enna later
      i see you guyz are working like everyday, judgin by the updates on the svn
      keep it up!

  • captainigloo 11:18 pm on May 19, 2008 Permalink | Reply
    Tags: , maemo, ,   

    Enna on maemo 

    I have’nt blogged for a long time, but today I have an exciting news. Enna works on N810. So for the moment it’s a bit quick and dirty, I have to polish packages, and enna have not a lot of functions yet, but as you can see in this video, EFL are very awesome. They are really really fast. A big thanks to all guys that have speed this amazing libs. You have done a really good job !

    You can download this litle video here : Format Mpeg4/ACC 58secondes 4.4Mo
    Or the youtube version :

    More coming soon …

     
  • captainigloo 9:21 am on March 11, 2008 Permalink | Reply
    Tags: , Mockups,   

    Mockups 

    I work hard on the next version of enna. I have review a lot of old old, corrected it and now I’m working on the future theme. People don’t like the previous brown version, so I decided to have a new theme more actual. Following, mockups I’m working on. I’m not completly happy with this mockups, and new version is in preparation. I think that to have a darker background, and saturated colors for selected parts could be really beautifull.

    mockup1

    Enna Mockup 1

    Enna Mockup 1

    mockup2

    Enna Mockup 2

    Enna Mockup 2

    I have design mockups for N810 too, and I would like have this kind of think on this beautifull device.

    Enna maemo mockup 1

    Enna maemo mockup 1

    Enna maemo mockup 1

    Enna maemo mockup 1

    Hope you like them 🙂
    Work is in progress to integrate these artworks in Enna code !

     
  • captainigloo 12:29 pm on February 1, 2008 Permalink | Reply
    Tags: ,   

    Evas Reflection #2 

    I played a little bit more with evas and reflection. In my last post I proposed a way to add reflection with Evas. But this code was false.

    Correct code have been added to enna, and you can view the result here :

    Evas Reflection

    Evas Reflection


    • First you need to add alpha layer, to enable premultiplication. It’s done when you load an image like png with alpha or if you add directly this alpha layer with : evas_object_image_alpha_set (Evas_Object *obj, Evas_Bool has_alpha)
    • When I copy pixess, I have add a bug. The pixels indexes were false when I flip the image. I have correct this in the new code.

    To be integrated in Enna, I have write a Evas_Smart Object, here is the code :
    http://enlightenment.org/viewvc/misc/enna/src/bin/enna_reflection.c?revi…

     
c
Compose new post
j
Next post/Next comment
k
Previous post/Previous comment
r
Reply
e
Edit
o
Show/Hide comments
t
Go to top
l
Go to login
h
Show/Hide help
shift + esc
Cancel